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Scope 
 
This document is intended for external SHA CAD users when setting up a standalone workspace 
for V8i Ss 10 software. 
 
Requirements 
 

• Installation of relevant CAD software, including but not limited to: 

o MicroStation Ss10 (08.11.09.919) 
o Power InRoads Ss10 (08.11.09.918) 

 
• ProjectWise Explorer client 10.00.03.280 or a later version. There are known 

compatibility issues with earlier versions. 

 
• Installation of SHA Workspace 2.x 

 
 
Topics 
 
Overview ....................................................................................................................................................... 3 

Enabling iDesktop Integration ...................................................................................................................... 4 

Disabling ProjectWise Login Popup .............................................................................................................. 6 

UCF Not Found Error ..................................................................................................................................... 7 

Requesting Support and Generating a Debug File ........................................................................................ 8 

InRoads SS2 and SS10 ProjectWise Integration ............................................................................................ 9 

InRoads ALG File: Access Control. ................................................................................................................. 9 

Enable “Geometry – Alternate Workflow with ProjectWise” via Variable Manager ................................. 11 

Additional Notes ......................................................................................................................................... 13 

 

https://www.roads.maryland.gov/mdotsha/pages/Index.aspx?PageId=29


 

 

 Projectwise-CAD Integration Troubleshooting 
3 November 1, 2023 

 

Overview 
 
Successful use of MicroStation/CAD with ProjectWise for SHA projects requires two things: 

• iDesktop Integration 
• SHA CAD Workspace Integration 

InRoads Ss10 users must also implement the instructions on ALG Access Control to configure 
their software for a multi-user project environment. 
 

To be clear, the two main goals of iDesktop Integration and CAD Workspace Integration will be 
achieved by closely following the instructions laid out in SHA's ProjectWise Installation Guide 
and the SHA CAD Workspace Setup Instructions. No additional steps are needed. 
 
This document is meant to provide supplemental information to explain and address the most 
common problems encountered during setup. 

 
iDesktop Integration is Bentley’s term for ensuring that your software, whether it is a CAD 
application or Microsoft Office, is able to browse the ProjectWise datasource (without using 
ProjectWise Explorer). 
 
SHA does not typically enable integration for Microsoft Office products such as Word or Excel. 
However, enabling iDesktop Integration for Bentley applications is absolutely necessary for 
effective use of the software. Failure to do so not only affect the ability to browse for DGN files 
in your project directory, but also prevents the proper attachment and display of reference 
files. 
 
SHA CAD Workspace Integration means that when you open a CAD file from ProjectWise, the 
software loads the appropriate workspace resources, including level libraries, custom lines 
styles, discipline-specific menus, etc. While the newer “managed” workspace will be loaded 
automatically, older projects using the legacy “workspace profile” may require some local 
configuration. 
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Enabling iDesktop Integration 
 
It will be immediately evident whether a software is integrated with ProjectWise if, when you 
select File > Open from within that application, a ProjectWise dialog box appears instead of a 
Windows dialog box. 
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iDesktop Integration should be enabled at the time ProjectWise is installed. Note the following 
screenshot adapted from page 2 of SHA's ProjectWise Installation Guide: 
 
If iDesktop Integration was not enabled at the time of installation, or if the CAD software was 
installed after ProjectWise, it may be necessary to Change the installation options via Control 
Panel > Programs and Features (to ensure that IDesktop Integration is turned on). In some 
cases it may be necessary to uninstall and re-install the ProjectWise Explorer client. 
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Disabling ProjectWise Login Popup 
 
One of the consequences of enabling iDesktop Integration is the ProjectWise login that appears 
when you first load the software from a desktop shortcut: 
 

 
 
Most users do not want to see the ProjectWise login popup when they are not actually using 
ProjectWise. Therefore, the SHA Workspace automatically disables this popup. The relevant 
configuration is contained in the mcm.user.cfg file:  
 
#=========================================================================== 
# Disable ProjectWise Integration unless the ProjectWise V8i Explorer  
# client is being used. i.e., the user won't be prompted to login to PWise 
#=========================================================================== 
%if !defined (_PWEXPLORER) 

PW_DISABLE_INTEGRATION = 1 
%endif 
 
Again, users need only follow the standard SHA Workspace Setup Instructions in order to 
implement this. 
 
Note that this configuration will continue to work for consultants whether or not they are using 
the SHA Workspace. For those who prefer to retain the login popup, “comment out” the three 
lines shown above by prepending each line with the “#” character:  
 
# %if !defined (_PWEXPLORER) 
# PW_DISABLE_INTEGRATION = 1 
# %endif 

https://www.roads.maryland.gov/OHD2/ReadMe.pdf
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UCF Not Found Error 
 
The most common integration error occurs when users try to open a DGN file from ProjectWise 
Explorer and receive the following error message (or slight variation):  
 

 
 
ProjectWise has failed to locate the workspace root directory. This is a clear sign that the 
workspace is not properly integrated. Please review the workspace setup instructions, paying 
particular attention to the variable named _MDOT_WORKSPACEROOT.  
 
If necessary, generate a debug file and send it to SHA Integrated Design System email: 
ids@mdot.maryland.gov 
. 
 

https://www.roads.maryland.gov/OHD2/ReadMe.pdf
mailto:ids@mdot.maryland.gov


 

 

 Projectwise-CAD Integration Troubleshooting 
8 November 1, 2023 

 

Requesting Support and Generating a Debug File 
 
If necessary, generate a debug file to share with SHA’s CAD support staff, as follows: 
 

• Right-click the ProjectWise DGN file and select Open With…  
 

 
 
 

• Select the option that has “zzz_DEBUG” in the Description.  

• Uncheck the option to “Always use this program” (UN-check!)  

• Check the option to “Open document as read-only”  

• Click OK.  

 
A message window will appear with scrolling text. When the scrolling ends, the last line of the message 
will indicate the path location of the newly generated debug file. (If the debug process is interrupted 
before displaying the output path, search for a file named msdebug.txt it in your local User directory: 
 

C:\Users\[username]\AppData\Local\Temp\msdebug.txt  
 
Locate this file and send it as an email attachment to ids@mdot.maryland.gov along with a brief 
explanation of your problem. 
 

mailto:ids@mdot.maryland.gov
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InRoads Ss10 ProjectWise Integration 
 
Working with ALG files within ProjectWise is different from working with ALG files on a shared 
network drive. This is because ProjectWise copies files to a temporary local location. Additional 
steps are required to establish Access Control for a shared ALG file in a multi-user project 
environment.  
 
*These instructions apply to the Ss10 versions of InRoads.  
 
SHA does not support any versions of Inroads older than Ss10, 
 

InRoads ALG File: Access Control. 
 
While working on a shared network drive, Access Control allows users to share a single ALG file 
among a group of users. InRoads uses Read-Write and Read-Only flags to keep track of which 
alignments (and the Cogo buffer) are being edited by which, thus preventing conflicts and 
accidental overwrites. A special interface is provided to exchange access control between users 
accessing the ALG file.  
 
To open the Access Control Detail dialog box, right-click on the Geometry Project name in the 
InRoads Explorer (either pane), and in the context menu that opens, select Details. 
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After selecting this menu item, the Access Controls Details dialog box will open.  
 

 
This dialog box has a selection list box and a row of buttons on the right-hand side of the dialog 
box. In the image shown, the Cogo Buffer and one Horizontal (alignment) are set to Read-Write 
Access and are shown as Locked By (a) User. Additionally, the Horizontal (alignment) is 
selected which enables all buttons, except for Check Out, since the alignment is already 
checked out.  
 
There is a version of this dialog box that works in a very similar manner outside of ProjectWise, 
but to get the proper function within ProjectWise, several additional steps are necessary. 
 



 

 

 Projectwise-CAD Integration Troubleshooting 
11 November 1, 2023 

 

 

Enable “Geometry – Alternate Workflow with ProjectWise” via Variable 
Manager 
 
The following steps must be taken for any user that will be sharing access to ALG files. On the 
InRoads Explorer, select Tools ► Variable Manager. This will open the following dialog box.  

 
Scroll down to the Command Behavior: group and check on the Geometry – Alternate 
Workflow with ProjectWise. Press the Apply and Close buttons.  
 
With this accomplished, ProjectWise and InRoads are now set to manage the Access Control of 
ALG file for multiple Users. 
 



 

 

 Projectwise-CAD Integration Troubleshooting 
12 November 1, 2023 

 

Lastly, Bentley recommends changing the default settings for how InRoads opens ALG files. For 
this to work as intended, you must be in a Preference (XIN) file with Read-Write Access. 
 
On the InRoads Explorer, select File > Options > Geometry and in the Project Options dialog 
box, select the Geometry tab. 
 
At the bottom of that tab, change 
the Default Access Mode for 
Horizontal Alignments and Cogo 
Buffer to Read-Only. 
 
Press the Apply button. 
 
Next press the Preferences 
button. When the Preferences 
dialog box opens, press its Save 
and then its Close button. This 
will save the Default Preference 
that loads when InRoads is 
launched. 
 
To complete the process, press 
the Close button on the Project 
Options dialog box. 
 
Note: Most XIN files in the SHA 
Workspace have this setting 
enabled, but in a shared 
environment, users can make 
changes to these. It is a good 
practice to periodically confirm 
that these settings are defined as 
shown. 
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Additional Notes 
 
InRoads uses the users Windows ID if possible, otherwise it defaults to the ProjectWise ID. 
When using the ProjectWise ID, inconsistent use of case in the ID may cause issues. For 
example, if a user connects to ProjectWise using all lower-case character in their ID and checks 
out an alignment, InRoads sees that users name as being all lower-case. If they save and exit 
without freeing the alignment and later log in to ProjectWise using a mixed case (or all upper 
case) ID, InRoads will see that user as a different user. As a result, that user will not 
automatically gain read-write access to that alignment. 
 
In order to take ownership of that alignment, that user has two choices. They can log back out 
of ProjectWise and log back in using the same case as they originally logged in, of they can use 
the “universal” free command that Bentley built into InRoads when they changed how the ALG 
file manages Access Control. To free any alignment no matter who the user is, the user can 
hold down the Ctrl key while selecting the Free command. 
 
If the user has read-write access to an alignment and saves the ALG but does not free the 
alignment, it remains checked out. This command behavior will frequently result in alignments 
being locked by a user when they are no longer in InRoads or even ProjectWise. It is therefore 
very important that users be made aware of this command behavior, but more importantly, 
how the Ctrl+Free command can free any locked alignment. 
 
Some methods of loading other InRoads support files can result in them being Copied Out and 
not Checked Out of ProjectWise. This may result in users making edits to the local copy of the 
file but not being prompted to check them back in and even leaving them unable to push their 
changes back to ProjectWise. Additionally, if other users have checked out, edited and then 
checked in one of these files, should another user update the file with a different version, the 
other users’ edits will be lost. 
 
It is therefore recommended that users verify that files are either checked out or opened read-
only before deciding to begin making edits. If the file to be edited is not checked out, a user 
should manually check it out and then, any edits they make will be saved to the checked-out 
copy and other users will be unable to check out the document.  
 
It is also recommended that users open the local document organizer whenever they exit an 
InRoads session to confirm that all checked out files are checked in or at the very least, the 
server copy has been updated. 
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